Calendar Tuesday, September 23, 2014
Text Size
   
  • You Are Here
deathpulse
Retail Kit
Posts:8
Karma: 0

OK - got all my parts... quick Q's on loop etc

#1 3 years, 1 month ago
Hello everyone! I just got some nice goodies from DD - this is my first "real" water build. Two quick questions - what should the order of my loop be? (i.e. output on water pump -> CPU block -> ???) and should I put the two water connectors on the black ice on the TOP or the BOTTOM when I install it? Items purchased below:


MC TDX i7 1366 CPU block with 3/8" fittings
DD GTX 570/570 GPU block with 3/8" fittings
Black Ice SR1 360 Radiator with 3/8" fittings
3 x Yateloon Low Speed Fans
DDC 3.25 12v pump
DD Rad Reservoir with 3/8" fittings
8 Feet 3/8" Tygon Tubing
Feser One Fluid
12 x 3/8" Hose Clamps
Arctic Silver 5 Thermal Paste
Black Series Tower 21 case with front usb/audio
[DD]JERM
Administrator
Posts:1626
Karma: 4

Re: OK - got all my parts... quick Q's on loop etc

#2 3 years, 1 month ago
Order doesn't matter too much...except typically this:

Reservoir - Pump - CPU

Now you don't have to go to the CPU after the pump but is typical. After that I recommend whatever gives you the cleanest route.

Radiator fitting up or down doesn't matter too much. Just may take a few extra minutes to get the air out of the system.
----------------------------------------------------------

We are here to help...just ask!!! www.dangerden.com/support
deathpulse
Retail Kit
Posts:8
Karma: 0

Re: OK - got all my parts... quick Q's on loop etc

#3 3 years, 1 month ago
Cool! I was actually thinking about putting the pump at the bottom right of the case, so ti would go:

Pump out -> GPU -> CPU -> Radiator -> Reservoir - > pump

Does this make sense?

In this config, if I put the radiator hookups at the bottom I think it is the most clean.
[DD]JERM
Administrator
Posts:1626
Karma: 4

Re: OK - got all my parts... quick Q's on loop etc

#4 3 years, 1 month ago
Should work just dandy for you!
----------------------------------------------------------

We are here to help...just ask!!! www.dangerden.com/support
deathpulse
Retail Kit
Posts:8
Karma: 0

Re: OK - got all my parts... quick Q's on loop etc

#5 3 years, 1 month ago
Excellent! So it won't really make a difference to run the GPU before the CPU? I am going to try to take my 2600k to 5.0 ghz :)
Red_Rain
Dual Loop
Posts:127
Karma: 0

Re: OK - got all my parts... quick Q's on loop etc

#6 3 years, 1 month ago
Take a look at what I did with a 2600K system setup: www.dangerden.com/Post-your-Rigs-Pics-an...-Bridge-in-Blue.html

I'm running a single D5 pump / 200mm Rad / CPU / 240mm Rad / GPU / Res loop and getting good temps across the system:

CPU never sees temps over 60c under full load 4.3 GHz overclock (over one hour).

GPU never sees temps over 50c under full load
(runs around 39c during FurMark test).

Either later this year or early next year I'm going with a DD rad box, add a SR1 360mm Rad, add another D5 pump, and add another EVGA GTX 580 Hydro Copper 2 GPU.
Time to create page: 0.28 seconds